3.6.4~3.6.6をリリースしてはいけない

  • 投稿日:
  • by



おやまぁ。



sqlite-announceから全文引用。



D. Richard Hipp


日付 2008/11/21 23:40


We discovered a database corruption bug yesterday in SQLite versions


3.6.4 through 3.6.6. This is an obscure bug. It has never been


observed in the wild - it was found by our internal stress testing.


It takes a contrived test case to manifest the bug. Hence, we believe


versions 3.6.4 through 3.6.6 are safe to continue using for


development work. But you may want to avoid releasing product


containing SQLite versions 3.6.4 through 3.6.6. We will release


SQLite 3.6.7 containing a fix as soon as we can.



開発内部のストレステストでバグが見つかったそうです。


テスト以外でこのバグの報告はまだないようです。


相当意地悪なテストをしないと再現しないということでしょうかね。


とにかく3.6.4~3.6.6は製品に含めてリリースするな、とのことのようです。